Navigation: Troubleshooting >

Data does not open in Google Earth

 

 

 

Is Google Earth "Pro for Desktop" installed?


1)Make sure Google Earth is installed on the computer.

2)How to install...

 

 

Check the browser's "downloads" area.


If you are using Firefox, Chrome, or Safari (that is, not Internet Explorer) the browser might be putting the file into its "downloads" area.

1)If so, go the the downloads area (from the browsers "Tools" icon) and open the file from there.

2)If there are many Earth Point files in the downloads area, then it might be difficult to know which one to open.

3)In that case, "clear" the downloads area, then click the Earth Point "View on Google Earth" or "Fly To On Google Earth" button again.  That way, there will be just one file in the downloads area to choose from.

 

 

Fix the computer's file associations (Windows computers only).


Sometimes the computer's Google Earth file types get mixed up.

 

Windows 10 workaround

1)Go to www.earthpoint.us/Townships.aspx

2)Click the "View on Google Earth" button.

3)However, "Save" the file instead of "Opening" it.

4)Open Google Earth.

5)Select "File", "Open" from the menu in the upper left corner of the Google Earth screen.

6)Open the file you saved in step 3.

 

 

Windows 10 Permanent Fix - first 3 steps are the same - save the kml file to your hard drive.

1)Go to www.earthpoint.us/Townships.aspx

2)Click the "View on Google Earth" button.

3)However, "Save" the file instead of "Opening" it.

4)Open Windows Explorer.

5)Find the file you saved on your hard drive.

6)Right click on the file.

7)Select "Open With", "Choose another app" from the pop-up menu.

8)Check the box "Always use this app to open .KML files"

9)Select "More apps" from the pop-up window.

10)Scroll to the bottom of the app list.

11)Select "Look for another app on this PC"

12)Find the "C:" drive on the left side of the screen.

13)Drill into "Program Files".

14)Then "Google"

15)Then "Google Earth Pro"

16)Then "client"

17)Finally, select the file "googleearth.exe"

18)Note - if you do not find this under "Program Files", then look under "Program Files (x86)"

 

 

Windows 7 or 8

1)Open the control panel.

2)If you are using Windows 7 or 8, on the right side of the top line, select "Large Icons" for the "View By" option.  If you are using Windows "Vista" switch to "Classic View".  If you are using "XP", please call for instructions.

3)Open "Default  Programs"

4)Select "Associate a file type or protocol with a program"

5)Wait about 15 seconds for the screen to fill out.

6)Scroll down to ".kml"

7)In the right column the option should say "Google Earth"

8)If not, double click.

9)If Google Earth is displayed select it.  If not, click the little down arrow to the right of "Other Programs".

10)If still not displayed there are two things to try.  We would either click the "Browse" button and find Google Earth – something like "C:\Program Files\Google\Google Earth Pro\client\googleearth.exe" or reinstall Google Earth.

11)Repeat for the ".kmz" file extension.

 

 

 

If you are using Windows XP...


If you are

 

1)Using Windows XP, and

2)You are not the administrator of the computer, and

3)You are the one who installed Google Earth, then

4)Google Earth will not open files.
 

The solution is to uninstall Google Earth, then have an administrator sign into your computer and install Google Earth.  Get Google Earth from http://earth.google.com


 

 

 

 

Copyright © 2019 Earth Point

Contact: [email protected]  (208) 860-6311